How Do I Stop CNN Videos From AutoPlay on Chromium-Based Edge

11

Does anyone know if there’s a way to stop CNN’s auto-play videos from playing on Edge?

Comments (12)

12 responses to “How Do I Stop CNN Videos From AutoPlay on Chromium-Based Edge”

  1. crp0908

    They didn't make this easy and it doesn't even work as advertised. All you can do is mute the video, not block autoplay.


    You may have to enable the flag that allows for the block option. Type edge colon slash slash flags into the address bar, then type media into the search box to see all flags affecting media. Check that Show block option in autoplay settings is set to Enabled. Then go to:


    ... > Settings > Site Permissions > Media AutoPlay


    Choose Block. Restart Edge.

  2. hrlngrv

    You should be able to install Chrome extensions from Google's Chrome Web Store. There's a Chrome extension named Disable HTML5 Autoplay which works for me. It also disables annoying autoplay videos on ZDNet and most other sites. It and AutoMute are must-have for me. Haven't checked, but there may be a Chrome equivalent for the Greasemonkey extension for Firefox. If you're willing to put in the effort, you might be able to use something like that to disable rendering video playback panes entirely.

  3. anderb

    The "AutoplayStopper" extension works well on all chromium-based browsers.

Leave a Reply