Startup page setting in Edge not working?

5

Is anyone else having an issue recently where their “startup page” in Edge is not-working?

If you go to Menu (…) > Settings > “Start, home, and new tabs” there is a heading titled “When Microsoft Edge starts” and under that is a setting labelled “Open these pages:”. I have set the Google UK URL there to open when I launch Edge.

However recently on both of my laptops, this has stopped working. Both run Windows 10 21H2, with Edge (Stable Channel), version 96.0.1054.43.

Now, whenever I open Edge, it disregards whatever I set as my “startup page”, and just opens to the “New Tab Page” instead. (The “Home button” URL setting, however, is still working fine).

I did some troubleshooting on one of my laptops, and found the only-thing that would-work was to create a new profile, which is not ideal as then all settings (such as per-site permissions and zoom-levels) get lost.

Is this happening to anyone else? I’ve only been able to find some people posting on the “Ask Woody” site about this so-far, but nowhere else…

Comments (5)

5 responses to “Startup page setting in Edge not working?”

  1. fikus74

    Yes, I'm having this issue. It started a couple of weeks ago.

  2. anoldamigauser

    I have found this to happen intermittently. It also seems to change my "New Tab page" customizations on occasion.

  3. lwetzel

    Not happening on my Windows 11 machine.


    • lwetzel

      But just after posting that it occurs to me that my post didn't help you with your problem. Appologies.

  4. Josh

    I had this issue a few days ago. I checked for Edge updates, let it install and restarted. Afterwards the page I defined came up as the homepage, as expected.