Google Chrome redirecting localhost to https

2

When I debug a Visual Studio project using Chrome the browser tries to redirect to the https equivalent of my web address. I do not have SSL enabled in the web project and the start URL is the http URL. When I debug using FireFox or IE I do not have this problem.

I did re-install Chrome which fixed the problem for a day. Without downloading any addons the problem happened again the next day.

What is making Chrome redirect localhost to https?

Network Inspect Shows: Request URL:data:text/html,chromewebdata Request Headers Provisional headers are shown User-Agent:Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.143 Safari/537.36

No preview and no response data in those tabs.

__________________________________________________________________________________________________________________________________

FaceTime for PC

Comments (2)

2 responses to “Google Chrome redirecting localhost to https”

  1. wright_is

    Google. They consider all http as insecure and want to force all connections to https. That said, it shouldn't be doing it if there is no https available. Does it do it to other external sites that are http only?

    I don't use Chrome, so I can't test. But I know that Google were talking in the summer about forcing the move to https. But it isn't practical for many internal devices on private networks, for example.

    My router and printer both offer only http on the LAN.

  2. waethorn

    What version of Chrome is that?

Leave a Reply