PSA for new-ish Surface users, our national nightmare is over

5

Reddit user fliflipoune just let everyone know on r/Surface that the new Intel Graphics Command Center (not the old Graphics Control Panel) is available to all newer Surface devices via the Microsoft Store app (I believe Skylake and newer). This is a big deal because there was no official, easy, safe and permanent way to turn off Intel’s D.P.S.T, which is probably the most common complaint Surface customers have. When D.P.S.T is enabled, it causes color banding in gradients, it ruined the excellent color accuracy and fidelity too. Things just looked weird and bad when it would kick in. I believe it would also effect screenshots when it would kick in (meaning the odd color/gamma compensation would be baked-in to screenshots/printscreen, which is ridiculous). I managed to turn it off via registry tweak last year but when I upgraded to 1809, it reset and I’ve been stuck living with this awful thing until today.

(I made a thread a couple of months ago asking Paul to ask Microsoft about this and strangely, Microsoft didn’t tell Paul about the new Command Center, they just told him that only the Pro 6, Laptop 2 and Go are compatible with the old Graphics Control Panel. I believe the Graphics Control Panel won’t even be updated going forward, the Command Center is the replacement and it solves this problem)

Comments (5)

5 responses to “PSA for new-ish Surface users, our national nightmare is over”

  1. jimchamplin

    Will these new Intel drivers and control software be available for older Intel graphics? HD4000-era?

  2. lvthunder

    They need to upgrade the nVidia drivers so I can use GPU acceleration in Adobe Premeire.

  3. ecumenical

    Huh. So that's why I've literally been watching color banding crawl across my Surface's wallpaper with nothing open on the device.

  4. lvthunder

    In reply to Salvador Romero:

    No it's trying to use the Nvidia card. It's just that the drivers are old. Premiere sees that and even pops up a warning telling you to get newer drivers. You have to turn off GPU acceleration to get it to work smoothly.

Leave a Reply