Has anyone successfully installed Windows 11 (stable version, not beta/dev) on a TPM-less machine?

Has anyone successfully installed Windows 11 (stable version, not beta/dev) on a TPM-less machine?

I know Microsoft does provide an official workaround for unsupported CPUs and for TPM 1.2, but has anyone bypassed TPM altogether and how have they fared in terms of updates?

Conversation 21 comments

  • wright_is

    Premium Member
    06 October, 2021 - 9:42 am

    <p>I haven’t tried. I need my machines to be stable and reliable… Not using them as an experiment.</p>

  • polloloco51

    06 October, 2021 - 11:14 am

    <p>I tried the registry mod, on a Dell Inspiron tower with a i5-4460 with no TPM to no luck. I might have to do a clean install and possibly swap the .wim files, from Windows 10 and 11 ISOs.</p><p><br></p><p><br></p><p><br></p>

    • polloloco51

      06 October, 2021 - 4:24 pm

      <p>Update!</p><p>I got Windows 11 successfully installed on the 2013 Dell Inspiron, with an i5-4460 processor! No issues at all!</p><p><br></p><p>In fact, all if the drivers installed without a hitch! Including the graphics, audio chipset and more!</p><p><br></p>

      • hidp123

        06 October, 2021 - 4:43 pm

        <p>How did you do it? </p>

        • polloloco51

          06 October, 2021 - 5:30 pm

          <p>I moved the Windows 11 install.esd into the Windows 10 ISO, on the flash drive. This tricked the Windows 10 installer, into installing Windows 11.</p><p><br></p><p>You will just need, the Windows 10 and 11 ISOs to do this.</p><p><br></p><p> Incredibly simple! </p>

          • polloloco51

            06 October, 2021 - 6:24 pm

            <p>I should add</p><p>I took the install.esd from Sources folder in Windows 11 ISO, and moved it into the same folder, in the Windows 11 ISO. Just like that. </p><p><br></p><p>It installed without any problems. It does show the Windows 10 Install screen. After restarting, it goes to the Windows 11 setup process screen. Windows actually seems more fluid than Windows 10, on the Inspiron.</p><p><br></p><p>To why Microsoft is barring PCs, is just confounding. It is revealing, Windows 11 can install on older PCs like this. </p>

            • polloloco51

              06 October, 2021 - 6:24 pm

              <p>This should say</p><p>I took the install.esd from Sources folder in Windows 11 ISO, and moved it into the same folder, in the Windows 10 ISO. Just like that.</p><p><br></p>

            • hidp123

              07 October, 2021 - 1:53 am

              <p>Thanks. So was this an upgrade or a clean install? I’m hoping to not do a clean install if I can avoid it. </p>

              • polloloco51

                07 October, 2021 - 7:45 am

                <p>I did a clean install. It is probably the best and only way currently. </p><p><br></p><p><br></p>

              • epguy40

                08 October, 2021 - 1:02 pm

                <p>also works with an upgrade install as well</p>

  • sfernley

    06 October, 2021 - 3:23 pm

    <p>You can do a clean install of the RTM version on a non TPM machine by using alternative installation methods to the standard installer. For example if you know how to use DISM to deploy the install.wim from the ISO this works great. </p><p>Still an unknown at this stage if Microsoft will allow you to update pc’s installed this way. I bet they will but only time will tell.</p>

  • StevenLayton

    06 October, 2021 - 4:29 pm

    <p>Its funny, half this site hates Windows 11, the other half is looking for ways to hack it onto their machines, lol.</p>

    • alastair87

      06 October, 2021 - 9:54 pm

      <p>My friend was amused when after weeks of whining about Windows 11 I’d upgraded my Windows 10 partition to it on day one . . .</p>

  • chriscarstens

    07 October, 2021 - 2:32 am

    <p>Can you put it on a Commodore 64? What’s the point of these bootstrap operations? Windows 10 works. Why install a new OS in what will probably be a handicapped operation? I know, "Because I can."</p><p><br></p><p><br></p><p><br></p>

    • Alastair Cooper

      07 October, 2021 - 6:17 am

      <p>Windows 11 is not compatible with a Commodore 64. It literally cannot run it, in the same way I cannot run 24GB ML models on my 6GB GPU, or in practical terms (without atrociously poor performance) run Windows 11 x64 on an ARM Mac. </p><p><br></p><p>Windows 11 is compatible at least for now with legacy PC hardware (Microsoft might yet release something with fundamental architectural differences but I doubt that will occur any time soon). The reason it doesn’t work by default is because of artificial restrictions where it analyses the hardware and decides it’s not ‘supported’.</p><p><br></p><p>That is *not* the same thing at all. One is an inevitable result of new technology being better than old technology. The other is a company trying to control its customers, in this case in a market where it is still a monopolist.</p><p><br></p><p><br></p>

    • polloloco51

      07 October, 2021 - 7:48 am

      <p>If you gutted the components inside and replaced it with a current generation low powered Intel Celeron board. </p><p><br></p><p>You very well could. </p><p><br></p>

      • Alastair Cooper

        07 October, 2021 - 7:54 am

        <p>Well, in a sense, but all you’d actually have is an x86 PC in a Commodore 64 case. You could even ditch the case and put it on your desk.</p>

  • dougkinzinger

    07 October, 2021 - 12:24 pm

    <p>I used the registry key and upgraded an OptiPlex 5050 (7th Gen Core i5) using the retail ISO without issue. Works fine.</p>

    • hidp123

      07 October, 2021 - 12:52 pm

      <p>Do you have TPM 1.2?</p>

      • dougkinzinger

        07 October, 2021 - 4:06 pm

        <p>Yes, in this case the OptiPlex 5050 has TPM 2.0 but 7th Gen i5, which is unsupported.</p>

  • epguy40

    18 March, 2022 - 7:36 pm

    <p>I have installed Win11 on a non-uefi based system w/out TPM several months ago and it worked fine</p><p><br></p><p>but it looks like the upcoming KB5011563 update for Win11 (build 22000.588) or newer makes Win11 show the "system requirements not met" watermark message on the desktop on non-TPM based systems</p><p><br></p>


Stay up to date with the latest tech news from Thurrott.com!

"*" indicates required fields

This field is for validation purposes and should be left unchanged.

Thurrott © 2023 BWW Media Group