Microsoft Edge and YouTube

6

Recently I’ve noticed that watching videos on YouTube has caused my Surface Pro 4 to overheat and the battery life lasts only 1 hour or so on Edge.  I go to Chrome and watch YouTube and everything is just fine.  Has anyone else had this happen?  Is this a Google response to Edge’s battery life ads?

Comments (6)

6 responses to “Microsoft Edge and YouTube”

  1. 5664

    Knowing Google, probably so!

  2. 5615

    tl;dr: There might be something going on hardware-wise with Edge and HTML5 videos, and you might find it better to avoid using Edge when watching YouTube. Or it could be something totally unrelated.

    Not sure if this is related, but for the longest time when I opened any tab with a video in it in Edge I would get the Windows 10 "blinking monitor." You can Google it and see many variations of the issue, but basically the monitor goes blank for 2-5 seconds and then comes back on -- and this happens at varying frequencies of "blinking;" it may do it every 5-10 seconds or every 1-5 minutes with no apparent pattern. Strangely, only one of my two monitors would do this -- the newest, biggest one. Of course, I suspected a driver issue, but all the drivers were current and rolling back to previous drivers didn't solve the problem. Needless to say, it's very annoying and I avoided using Edge. 

    Then, the other day after updating Chrome to the latest version, it started doing it with Chrome, too. Again, I suspected driver issues. After much fiddling around, nothing changed. So, I started to focus on Chrome. What had changed in Chrome to cause it to do this, too? Apparently, the latest version finally flipped the switch and made HTML5 video the default rather than Flash. I'm not sure why that alone would cause the problem since many web sites have been using HTML5 for video for quite some time (such as YouTube) and it never seemed to be an issue with Chrome in the past. Anyway...

    More Googling and I found a web page with about 10 possible solutions all focused on changing various Chrome settings. I started making some of the changes and nothing seemed to work. Then, I got to the part where it said to disable "Use hardware acceleration when available" in Chrome's advanced settings. Once I did that, the problem went away and hasn't happened, again (in Chrome, anyway).

    So this is a long-winded way of saying that maybe there's something going on hardware-wise related to Edge and YouTube's use of HTML5 video. I'm not sure if Edge allows you to change those kinds of settings like Chrome does (I looked quickly, but didn't see anything), but that might be an avenue to explore. It would be strange for this to be the cause on Microsoft's own hardware since Microsoft seems to maintain that the need to disable hardware acceleration is ultimately a driver issue. Nevertheless, you might find that avoiding Edge when watching videos alleviates the problem...or not.

  3. 5530

    Not seeing this problem in my end. Doubt Google would do such a thing though.

  4. 5523

    I also doubt Google would do that, but, who knows.  If you got some time to kill try other video sites and see if the same thing happens. 

  5. 1063

    I'm guessing it is a hardware HTML5 thing.  Is there a way to reset Edge to defaults in the off chance a setting was changed?  It's weird that it only effects youtube.  Other streaming services such as Twitch, Vimeo and miscellaneous tech sites, don't have this overheating/battery usage.

    • 5615

      In reply to rtodd_us:

      I haven't found anything like a "reset to default settings" button in Edge, but if you Google it you'll find web sites that discuss "resetting" Edge. Most of them discuss going into Settings > Clear browsing data and selecting all the choices. No idea if this really works, but it (or the much more complex PowerShell procedure to do essentially the same thing) seems to be the only choice.

      Also, worth a try might be to disable hardware acceleration for Edge and IE and see if that solves the problem. I'm not sure if disabling hardware acceleration will introduce any new issues, but I guess there's only one way to find out.

      1. Go to Control Panel.

      2. Click on Internet Options.

      3. Click on the Advanced tab.

      4. Under Accelerated Graphics check the box that says "Use software rendering instead of GPU rendering".

      5. Restart your computer.

Leave a Reply