Store Only Mode vs Portable Apps

1

In order to answer my own question I raised in the article on “Store Only” mode, I set up a Fast Ring build up in a Hyper V VM and gave running portable apps a shot, The TL;DR version is the results were mixed, but I was able to run Firefox even though I was in Store Only mode.

First up – the “Portable Apps Platform” installer, which installs a tool on a usb stick to help manage portable apps wouldn’t install (Windows recognised it as an installer and blocked it). So I had to run that on non store only mode machine (in this case, the PC the VM was running on top of). While still on the host, I used the tool to install Chrome on to the usb key.

Switching over to the VM and sharing the USB key with the VM, I opened up the “Start” app on the USB key, which ran the Portable Apps “Start Menu” – which did show that non store apps will run, just not install.

I couldn’t get Chrome to work – it started but no pages would load. I have feeling it has more to do with either the VM and/or the build than it does with Store Only mode.

I returned to the host machine, installed Portable Firefox to the drive and then returned to the VM. Firefox ran. Not very well (it would often stop responding) but pages would eventually load.

I then tried installing a Portable App while on the VM (the Portable App “Start Menu” includes an app gallery). Surprisingly, I was able to get the Portable version of VLC to install and run from the USB key. I’m guessing whatever code is running to check that an install is happening can’t tell that’s what happening when the Portable Apps tool is installing to the USB key.

Comments (1)

One response to “Store Only Mode vs Portable Apps”

  1. hrlngrv

    I had mixed results with Store Only mode. I tried a few things I had around. WinMerge's .EXE installer and MSFT's very own CalcPlus.MSI both installed without Windows 10 Build 15042 blocking them. Opening PortableApps .EXEs in 7zip as if they were zip files let me copy programs to any directory to which my standard account has write permission, and I could then run them with no gripes from the OS. A bit more complicated, but it's not strictly necessary to run the PortableApps installer.

    I suspect Windows 10 catches some but not all system calls used during typical install operations.

    ADDED: Gets worse. I just installed 15046, and it resets the Install Store Apps Only option. NBD upgrading from 1607 or prior, but leads me to wonder whether 1711 (or whatever) would leave 1703's setting as-is.

    ADDED MORE: Even worse, the PortableApps installer for Google Chrome does result in the new dialog saying only Store apps may be installed, but the PortableApps installer for Q-Dir runs just fine. Maybe the new feature looks for particular program names. Weirder and weirder, and little chance MSFT will provide useful info.