Firefox 61 breaks site?

Avatar
13

When I updated to Firefox 61 I could no longer get onto the site. I tried Chrome and it isn’t the site Here is the msg:

Secure Connection Failed

An error occurred during a connection to www.thurrott.com. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG

  The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.

  Please contact the website owners to inform them of this problem.

Comments (13)

13 responses to “Firefox 61 breaks site?”

  1. Avatar

    simont

    I am also using Firefox 61 but I am not getting an error messages on the site.

  2. Avatar

    Oasis

    I just updated Firefox on W8.1 and at first it didn't work and then after clicking retry once or twice it loaded. The original post was from my Windows 7 machine and it still isn't working properly.

  3. Avatar

    Oasis

    Did the same on my Windows 7 Laptop (old Sony Vaio) and it didn't load it but I clicked retry and it worked. Went back to the original offender and it took many attempts to get it to retry but it finally played nice and I reloaded Firefox 61 and it still worked. Very weird, only this site wouldn't load. Working OK now.

  4. Avatar

    ErichK

    Hmm, upgraded to 61 just now on W10 Spring Update, but no issues.

  5. Avatar

    Oasis

    Did it again this morning on my Main Desktop, but when I clicked retry it sat there for a while then got into the site.

  6. Avatar

    Oasis

    Happened on my old Win7 machine in the back which is the 4th different machine with this error. 3 of 4 are Windows 7, 1 is W8.1....

    Any thoughts on what this issue is?

  7. Avatar

    infloop

    After testing that the site works just fine with Firefox 61 on both Windows 7 and Windows 8.1, I did a search online and found this reddit thread: https://www.reddit.com/r/firefox/comments/8rilyj/ssl_error_rx_record_too_long/


    It appears to be a problem with TLS 1.3 and AV vendors with their HTTPS scanning feature turned on being unable to handle TLS 1.3, as Firefox now uses TLS 1.3 where available, including on google.com and this site (it looks like Cloudflare has it turned on by default, which I believe this site uses).

  8. Avatar

    MacLiam

    No errors with FF61 on Thurott.com (or any other website) here. I wish you success in solving your problem.

  9. Avatar

    jasonmorgan

    Mozilla doesn’t break out the precise numbers for Firefox, even though the agency does say “half a billion humans around the arena” use the browser. In other phrases, it’s a chief platform that net builders should keep in mind. Biker Leather Jacket

  10. Avatar

    Oasis

    It solved itself, about 3 days after I got those messages it stopped doing it on all of my machines. I didn't change anything, teething pains?

Leave a Reply