Has this site too much content?!

On from a post last week about logging in/logging out problems, I wonder whether “thurrott.com” has so much (great) content that it is bursting at the seams. I emphasise that ALL the content is great, but it is so slow to load in any browser. Yesterday, there was a Cloudfare “pop-up” about “checking my browser” and that it would take 5 seconds to move on. It didn’t, it took ages. What was that all about? I gave up waiting and returned to the site 30 minutes later, after having to log-in to premium once again, of course. That problem has not been resolved, BTW.

I know BWW is a small concern, but I understand that there is only 1 IT guy. I think he needs some help, fellas. The content is always worth the frustration and hassle, as far as I’m concerned, but I reckon it could certainly put off some new visitors, if not older ones.

Conversation 13 comments

  • Paul Thurrott

    Premium Member
    29 April, 2022 - 10:47 am

    <p>Thank you. And sorry about yesterday, we had some kind of an episode for sure. </p><p><br></p><p>I’m doing an AMA with our web guy, Nick, in late May to go over all the site stuff, and this will be a great opportunity for you and others to chat with him and find out what we’re doing to fix the site. I’ll post the details soon. </p><p><br></p><p><br></p>

    • navarac

      29 April, 2022 - 12:43 pm

      <p>Thanks – I’ll look out for that.</p>

  • dftf

    29 April, 2022 - 10:58 am

    <p>Yeah, no-idea what was going on yesterday: <strong>Error 524</strong> and <strong>521</strong> error-pages from <em>Cloudflare</em>, or "service unavailable"; or a <em>Wordpress</em> error in the comments area saying the site has an "unspecified security risk" or something. Sometimes it loaded-up <em>very </em>slowly, but into a tablet-formatted UI version, designed for at-a-guess 800×600 width.</p><p><br></p><p>Even when it does work though there are odd issues: every time I create a forum-post, it goes to a "Shoot, we can’t find the page you’re looking for" landing-page, but the post does later appear. Sometimes when you add a comment on an article, the site will reload without your comment; but reload the page and it’s there. Or the site hangs, then goes to a "It appears you’re adding a duplicate comment" warning, you click back, and your comment it there just once.</p><p><br></p><p>Sometimes the photo in the top-right of an article (e.g. of Laurent) changes to the profile-photo of the most-recent commenter. Profile images for users also randomly sometimes work, sometimes don’t.</p><p><br></p><p>And then, even beyond the technical-issues, there are the various odd decisions like allowing free-members to view 3 free articles a month, to which they can comment on, but not see any of the comments. Or if a Forum post is created by a Premium member, free-users cannot view it. (It would be nice if such posts maybe had <strong>[P] </strong>at the start of the title, or something, to distinguish them as-such).</p>

  • darkgrayknight

    Premium Member
    29 April, 2022 - 12:06 pm

    <p>I was connecting to the rss feed for thurrott.com, but now it stopped returning and appears to think I’m DOS’ing it.</p>

    • dftf

      29 April, 2022 - 12:09 pm

      <p>RSS feeds are still a thing…?</p>

    • alexoughton

      Premium Member
      02 May, 2022 - 8:04 am

      <p>Same problem for me too. Not sure if there’s a way to access the RSS at all with this CloudFlare protection in place the way it currently is.</p>

  • LT1 Z51

    Premium Member
    29 April, 2022 - 12:24 pm

    <p>I hate whenever I have to see that idiotic Cloudflare loading screen. So annoying. Not just here but any place that uses it.</p>

    • jimchamplin

      Premium Member
      01 May, 2022 - 10:01 pm

      <p>Guess it’s better than the alternative, though ,right?</p>

  • harrymyhre

    Premium Member
    01 May, 2022 - 5:57 pm

    <p>i never have any problems with ths site</p>

  • darkgrayknight

    Premium Member
    03 May, 2022 - 7:04 pm

    <p>I thought it was only my VPN use, but even disconnected, I get Cloudflare checking that I’m not DOS attacking the site. This is for both the rss feed (which should have some greater flexibility) as well as the website thurrott.com.</p><p>Did something get turned on that causes this to be checking so much more now and not returning rss feeds?</p>

  • navarac

    05 May, 2022 - 8:58 am

    <p>….and today I got a FULL page screen about "our partners", cookies etc. Wouldn’t go away. It is really off-putting, fellas.</p>

  • lezmaka

    Premium Member
    05 May, 2022 - 11:02 am

    <p>Same issue with RSS feeds for me. I used to use a browser plugin called Feedbro that worked for this site and Petri. I recently switched to a self-hosted instance of Tiny Tiny RSS and it was always getting errors trying to get the feeds. So I ended up removing the feeds from TTRSS and not surprisingly, I found myself not coming here very much at all.</p>

    • alexoughton

      Premium Member
      19 May, 2022 - 11:27 am

      <p>Same here. I’ve tried multiple methods of getting my RSS feed working again. Each works for a while before being thwarted by CloudFlare again. Good demo of CloudFlare’s anti-bot protection I suppose but I’m going to find myself unable to discover articles on this site without the RSS feed working on my home page. This is probably going to be the end of my Premium subscription if it doesn’t come back.</p>

Newsletter

Stay up to date with the latest tech news from Thurrott.com!

"*" indicates required fields

This field is for validation purposes and should be left unchanged.

Thurrott © 2023 BWW Media Group