Google Fi + iPhone = no MMS

Avatar
13

Trying to get some iPhones set up on my mom’s and my phone on my Google Fi account. One is an iPhone 7, the other an XS. Popped the SIM cards in and logged into iCloud and everything works fine except mms. iMessage obviously works fine. SMS seems to work, though it is hard to confirm as most people I’ve texted in the last decades are now MMS threads but I did get a few political solicitation texts last night so I’m assuming that is working fine.

I have followed Google’s official instructions (https://support.google.com/fi/answer/9293147?p=sms_send&visit_id=637400121939650345-2118764725&ios=1&rd=1). I contacted support and after an hour of them trying things they eventually “escalated” it and now I’m waiting to hear back.

Anyone dealt with this? Suggestions? Halp…

PS: Hey everyone!

Comments (14)

14 responses to “Google Fi + iPhone = no MMS”

  1. Avatar

    DerOi

    While not an solution but a work around: I installed google hangounts, using the same account the Google Fi was registered to. Suddenly all SMS and MMS where visible there. I can send and receive via hangouts without a problem.

    Hope it helps.

    Cheers.

  2. Avatar

    wright_is

    Interesting. MMS never really caught on over here. I sent an MMS to see how it worked back in the early noughties and my brother sent me one around 2008. I think those were the only 2 MMS I've ever sent or received. I didn't even realise it was still a thing.

    Now, everybody seem to use Telegram, Signal or WhatsApp.

  3. Avatar

    echorelay

    I specifically recall a section within APN settings (I used to have Fi on an iPhone) which required adding specific Google Fi MMS configuration settings. I presume the app pointed you in this direction already?

Leave a Reply