Surface Book 2 Wake/Power On Issues

12

A few months ago, I got top dollar for my Surface Book (512GB Model) and picked up a Surface Book 2 (512GB) and I’ve been extremely happy with it. Until now…

Over the last few days, it will not power on by the button. It simply will not power on from sleep/hibernation. Same goes if it is a full power down. It will not power on at all.

The simplest workaround is to detach the screen and it will power on with the button. If I leave it attached, I have to do the 12 second button press and then back on and then it works. Both of these are unacceptable.

Is anyone encountering this? Is this a hardware issue? I don’t want to have to swap it out. I love this one and don’t want to have to replace it. I hope it is fixed with a firmware update. I just hope it won’t take too long.

Comments (12)

12 responses to “Surface Book 2 Wake/Power On Issues”

  1. wolters

    I discovered that I never got the last round of firmware updates. I manually applied them and for now, it seems to be working.

  2. jwpear

    Sounds like something is up with the base. Any chance you could try another with a friend or colleague? Or maybe take to a nearby Microsoft store and try another base there?


    We have a Surface Laptop that we got back in December. My wife is the primary user and uses it pretty heavily. She likes it. I just recently noticed some of the firmware updates did not apply automatically. It is puzzling. My guess is that the machine is going to sleep before it has applied the updates or it wants to be plugged in before applying firmware updates. I'm going to have to manually check this from time to time to see if I can pinpoint the issue.


    I just got a used Surface Book 2 from Swappa about two weeks ago. It's pretty nice. I have observed one instance where touch started acting oddly when I detached it from the base and restarted the slate. I had to reattach to the base and restart to resolve. Feels like a driver issue. At least I hope that's what it is. It's in warranty through January 2018. I tried chatting with Microsoft and adding Microsoft Complete, but was fruitless.

    • wolters

      In reply to jwpear:

      It seems, for now, to have been the firmware. Like your wife's Surface Laptop, I seemed to have missed the last firmware update. I do remember it being mentioned in the tech blogs that it was out but I thought it was funny that I never got it. I did contact Surface Support and they had me manually install the recent firmware and it seems to have fixed it.

    • wolters

      In reply to jwpear:

      I agree it has to be the base. It started again last night when I got home. I did another power down and tried the power button and it didn't work but gently pushed it down some so it could be sure it is in the base firmly and then it worked.


      I also know when I reattach, the "Attached" message is very slow to appear and sometimes the trackpad takes some extra seconds to work.

  3. wolters

    UPDATE - Got home from work last night...still had power issues. Had to detach for it to power on correctly with the button. I've updated my case with Microsoft.

    • jwpear

      In reply to wolters:

      Not good news. Hope Surface support can get you going.


      If you have a Microsoft Store within reasonable distance, I suggest traveling to it for support. My closest is a four hour round trip. I used it back in the Band days and they swapped my Band 2 out with no questions asked. Obviously a much less expensive device, but still, the service was fantastic.


      I haven't had any major hardware issues with my Surface Pro 3 (which is currently listed on eBay) or our new Surface Laptop. So can't say that I've tested the Microsoft Store support waters with Surface. But I've heard the support is good.

      • wolters

        In reply to jwpear:

        I know it is normal to always get a "refurbished" model if you need a warranty replacement but that is hard to swallow when you spend $2200 for a Surface Book.


        I'm in Little Rock so the closest Microsoft Store is in Tulsa, which is 4 hours one way. But if there is a chance they can fix or replace it on site, I may get up Saturday and do it.

        • jwpear

          I think you stand a better chance of getting a new one going in to the store than calling support and working through a mail exchange. Just be sure to call the store and get an appointment.


          Did you purchase Microsoft Complete? That might help too.

  4. derylmccarty

    Have the same problem with my SB2 256. Hold button for 10-12 seconds and nada. sometime doing it a second time will elicit a white windows logo and a very fast start. I also agree that it works better if the "tablet" is detached. But what a pain in the ...


    I am an Insider so will look for your "complaint" and add to it.


    New data: if I unplug my SB2 and just use the mated tablets and base, when I push the button for 3-5 seconds it works. Then I plug it back into my Surface Dock and all is right with the world. Except that the battery doe not charge the same as before. sigh.


  5. wolters

    Thanks for all of the tips and advice. I pretty much believe it is the base. If I eject (but now power on) and then re-attach, I press power normally and it works.


    I'll continue to troubleshoot with Microsoft today.

  6. wolters

    POSSIBLE RESOLUTION - I noticed that the NVIDIA device in DEVICE MANAGER was greyed out. So I uninstalled it, rebooted, ran sfc scannow for good measure. I powered off my Surface Book 2 and turned on by button and it worked. Did it again and this time left it off for a while longer and closed the lid. Powered on again and it is powering on normally.

  7. wolters

    I just found this forum post after the fact but it is more widespread than I knew...


    https://bit.ly/2LE1gsx

Leave a Reply