Edge 91 Won’t Load My "Specific Page" at Startup

Avatar
8

I have always had Edge set to load a specific page on startup, rather than the “new tab” page, but with Edge 91, it always starts up to the “new tab” page, regardless of the “on startup” – “specific page” setting. Tried suspending any extensions, with the same result.

Tested with a clean profile, and the specified page DID load at startup, along with a “new tab”.

Then tested with the “continue where you left off” setting, which also appeared to work on my original profile, with an added “new tab”.

Odd behavior.

Anyone else seeing this?

Comments (8)

8 responses to “Edge 91 Won’t Load My "Specific Page" at Startup”

  1. Avatar

    navarac

    This, together with re-setting the default app to old Edge (!) to read *.pdf files in Outlook (Desktop) on OS update, is symptomatic of Microsoft's wish as HyperUsers to impose their will on user's of Windows 10. I don't believe for one moment that this is not intentional. The number of settings that get arbitrarily changed on an OS update gets longer each time.


    They have lost my trust, and as I commented elsewhere (probably to the point of boredom), my use of Windows, Edge and everything Microsoft is reducing rapidly. Only one PC now - for gaming- the rest are Linux. Shame really, Windows has served me well from the start, but Windows 8 was when the rot set in. Pity they didn't just go back to Windows 7 and progress from there.

  2. Avatar

    timo47

    I'm on Edge 91.0.864.37 and don't have this issue. Startup page is set to Google, and that's what opens when I start Edge.

  3. Avatar

    tomurphy

    I have the exact issue with Edge 91 as described in the original post including the same results with the attempted solutions

  4. Avatar

    tomurphy

    seeming fix for this issue...in Edge "settings", go to "reset settings" and "restore settings to their default values". A popup window will indicate items that will be reset... "on startup" to "open a specific page" can be reset ... any installed extentions will have to be turned on and other of the reset options will need to be restored

  5. Avatar

    tomurphy

    sorry...apparently reset settings worked because search engine was reset to Bing,.. if default search engine is changed to something else original problem reoccurs

  6. Avatar

    ourmaninny

    UPDATE - I'm not sure if Edge was updated or not since I'm traveling, but the problem seems to be resolved. My intended start page now loads at startup.

  7. Avatar

    jedi dwight

    You might look into the Chrome extension New Tab Redirect to replace the New Tab function with your desired homepage. I've had to use add-ons like this for Firefox to keep using the browser like I prefer, versus how some browser designer deigns.

Leave a Reply