Error 0xc0000142 and Office 365 Personal

Avatar
4

Hi everyone,

This seems to be my season for issues – I’m now finally running 1903 The May Update, but it seems that my office 365 Personal installation is, in a word, borked. Whenever I click on one of the Office apps (Word, Excel, it doesn’t matter), the click to run installer starts – odd, because this was installed on my system previously. The installer runs, and seems to perform the install (more on that below). I then click on the app, and it once again shows the orange “Installing Microsoft Office” splash of the click-to-run, then dies at the end throwing up the above error code an no other real information.

I have tried several ways to fix this, most of which have come from searches landing me at MS support pages. If I have failed to mention trying something on one of those pages, it’s generally because I have and these are the more extreme attempts after it. Here’s what I’ve tried:

  1. Modify the installation through settings.
  2. I have tried the offline one – ends up as above.
  3. I have then tried the online one – ends up as above.
  4. Uninstall Office using the utility, then reinstalling via the click to run installer. Ends up as above.
  5. Uninstall Office using the utility, then reinstalling via the MSI installer. Ends up as above.
  6. Uninstall Office using the scrubbing utility provided by Microsoft.
  7. Allowed the utility to run and reboot.
  8. Installed via the MSI installer.
  9. Ends up as above.

Essentially, I’ve tried whatever I can. I’m a licensed user of 365 Personal for many years, and while for the longest time it was for convenience and quite casual, I have need of it now at home – and of course that’s when the fun starts.

Has anyone experienced this? Can anyone point me in the right direction? I’m now being forced to use the web apps, which isn’t terrible, but I really would like my local copy of the apps back.

Comments (4)

4 responses to “Error 0xc0000142 and Office 365 Personal”

  1. Avatar

    wright_is

    Have you tried the repair option?

    Take a look at: https://officeerrorcode.us/0xc0000142-error-code-microsoft-office-2013-2016-365-how-to-fix/

    According to Microsoft, the problem was fixed with the 1803 release, so it is strange that is is happening with a new install.

    Do you have a proxy? Have you tried removing the Office directories and registry entries, before re-installing?



    • Avatar

      ommoran

      In reply to wright_is:


      Thanks for the suggestion. No proxy here, so that didn't work. Yes, after the scrub I ensured that I had removed the office directories.

      • Avatar

        wright_is

        In reply to ommoran:

        And removed the Microsoft Office branch of the Registry from HKLM and HKCU? (HKLMSoftwareMicrosoftOffice... and HKCUSoftwareMicrosoftOffice...)

        I had a problem with one machine refusing to let Office re-install. I wiped out all registry entries for Office and after that, it installed without any problems.

        • Avatar

          ommoran

          In reply to wright_is:


          Interestingly, I have found that if I try and run it from Start, it tries the upgrade trick. If I right click and run as administrator, it runs as normal, except I get the security screen where I have to click yes, this program can make changes.


          It seems that even though my MSA is an administrator on the computer, it doesn' t have "ownership" of the drive, and the ownership might be what is causing the issue?

Leave a Reply