1803 was a disaster

6

Well, I thought I would go ahead and update. After 2 days, I gave up. It would run fine for maybe 10 minutes and then the interface (desktop, start button, right click) would just stop responding. The machine was not locked up….Mouse still worked. To me, it’s seems like there a process triggered after several minutes. And this was both with an update and a complete clean install (wiped partition table). This is the first version that I have ever had any serious issues running.

No doubt, they’ll get it right and in fairness, I forced the upgrade so I’m not saying Microsoft wrecked my machine! You install an insider build, you agree to take the risks. Just saying, I would wait until it is offered and not go get it….

Comments (6)

6 responses to “1803 was a disaster”

  1. Paul Thurrott

    Having experienced three blue/green screens with this thing (two on 17133 and one on 17134), I'm also curious what the heck is happening here.

  2. wright_is

    Mine has been running stable since I got the last update this week, although I've only been on the Spectre x360 for about 3 hours since the upgrade, I don't have much time for testing at the moment.

    I haven't experienced any crashes or lockups yet...

    • bharris

      In reply to wright_is: Funny thing....As long as I just left it alone, it would run all day. But literally, trying to run just about anything, it would freeze in a few minutes. I bet I did 20 hard reboots in the past two days. At this point, I am sort of gun shy and having Pro, I plan on deferring this update for at least a few weeks


  3. StevenLayton

    Nah, the 1666 Fire of London was a disaster. A buggy pre- release of 1803 is an inconvenience. :)

  4. Lauren Glenn

    At least you got it to install. Honestly, it seems like you should do an SFC /SCANNOW.


    My GPD Pocket crashes with GSOD pointing to Intel power management drivers. Something that I wish the update process would've detected as a problem.... Guess I'll try again on Monday and see if they fixed it.

Leave a Reply