1903 is available to Release Preview insiders

Avatar
2

It’s currently installing on my SP4. However I also got the ‘unsupported hardware’ message about having an SD card installed, even though the link explaining this issue made it sound as if this is fixed in the latest insider preview builds.

Either way, I removed the SD card and it’s installing right now.

Comments (2)

2 responses to “1903 is available to Release Preview insiders”

  1. Avatar

    bharris

    I had the USB issue on my laptop which had a flash drive but on my desktop, with 5 USB hard drives, it worked fine without disconnecting anything. I've been running it on both for about a week without any issues. Hopefully, they are working on a solution. We know enough to figure it out but for automated updates, it is going to be a problem. I thought they had already fixed it....

  2. Avatar

    jimchamplin

    All of my machines are on it. ?


    Seems much more finished and polished than 1809, but then Whistler build 2250 was more polished than 1809.

Leave a Reply