win 10 network/ethernet problem

18

I have an old win xp pc with a DAVICOM network adapter connected to a Pace 4111N gateway using Ethernet cable. That setup works fine.

I also have a win 10 Dell desktop pc with a Broadcom NetXtreme 57xx Gigabit Controller. When I move that Ethernet cable to my Dell desktop pc it takes minutes to open a web page and most of the time I get “server not found”. Win 10 says that I have an internet connection, the diagnostics say no problem found, the device manager says the device is working properly and the router shows a connection to the pc. Any ideas on this? Thanks

Comments (18)

18 responses to “win 10 network/ethernet problem”

  1. 5615

    No specific ideas, except to say that I've more recently experienced degraded Internet service on my PCs, too; to the point where even Google.com won't load sometimes. Often, troubleshooting doesn't find any specific problem ("No problems found. Is there a specific web site you're trying to reach?").

    There are so many moving parts that it may be hard to track down any one thing. Our Internet service provider has had some well-publicized issues lately; nothing across the board (like a total blackout), so hard to know if that's a primary issue. Then there's all the DDoS stuff going on; hard to tell if the issue is on their end or my end. At the local level, it has sometimes been the case where rebooting the modem/router clears up connection issues (primarily wifi-related), or switching to a different browser (I mostly use Chrome; sometimes switching to Edge or Firefox temporarily works with a web site that Chrome suddenly decides it can't load) or using a VPN. Sometimes, Windows 10's downloading of updates brings the network to its knees. We haven't quite gotten it to fully respect QoS settings, yet.

    So, who knows? It could be the service provider, specific web sites, local hardware, local software, or some combination of any or all of the above. When the stars align and everything just works, it's great. When it doesn't...

  2. 9341

    Thanks everyone for your help. Problem solved-for now. I plugged in the wired connection, watched the bandwidth saturate immediately so I walked away. Two hours later the download stopped and the network is mine again. Something big was downloaded from the update server but it was not an update because I had checked for updates with the wi-fi connection 10 minutes before I plugged in the wired connection.

    I hope that was a one time-first time download and is not repeated again.

     

    • 5615

      In reply to norton2002:

      Unfortunately, it'll probably happen regularly on a wired connection if you're using the Home version, every time Microsoft decides to push out an update -- which seems to be random these days.

      • 9341

        In reply to offTheRecord:

        Yep. I gave up on the Ethernet connection.

        It happens every time I make a wired connection. Today it sucked from Azure as soon as I turned on the computer, not the usual update server. So I set the Ethernet to metered in the registry. Win10 pro ignores that setting. I don't know how anyone with slowish wired broadband can put up with this system. Why can't I tell the system when I am not using the internet so it can check for update then?

        They will have to pry windows XP from my cold, dead hands.

         

  3. 180

    MJF mentioned on Windows Weekly recently that one of the more recent Windows Updates introduced a DNS issue. I'd check to see if getting fully up to date fixes things. Check internet settings: are you getting DNS/DHCP correctly, or are things manually set on the deskop for some reason? Can you ping out/resolve DNS through the command line quickly?

    • 5593

      In reply to Polycrastinator: I definitely agree that it has introduced some sort of DNS error.  I'm getting "unable to connect" errors left and right.  But most notably it is with any site related to Google.  I have found that I can only connect to those sites, including YouTube, by switching to InPrivate mode or using a browser other than Edge or IE11.  This behavior has been exhibited on PCs, tablets and Windows Mobile devices, and on completely unrelated Microsoft accounts.  When I pulled up the Developer Tools to see what might be revealed in Edge I discovered instances where attempts to connect to YouTube generated a 301 redirector error.

       

    • 9341

      In reply to Polycrastinator:

      I have not had any of the issues that ofTheRecord describe with my old xp system. I move the Ethernet cable back and forth between the xp and 10 systems and xp works EVERY TIME. I ran both Firefox and Edge and both browsers behave the same slow way on any site that I tried.

      I added a Ralink Tech 802.11n USB wireless LAN to the win 10 pc and it works great. (By the way, I found that if you have a wireless connection and you plug in a wired connection, win 10 will connect with the wired and drop the wireless connection)

      So all indications are that my win 10 is misbehaving with the Broadcom net controller. Any thoughts on how to proceed. Thanks.

  4. 9341

    I met the enemy and it is Microsoft. I open resource monitor and watch the network performance. As soon as I make the wired connection, the data rate jumps to 1.4 Mbps and saturates my bandwidth. (I have DSL with 1.5 Mbps down and 0.4 Mbps up.) Looking at the hog process it is svchost.exe (net svcs) at address 13.107.4.50.

    Googling this address shows that it is the Microsoft update server. What is it doing?.
    I just did a manual update request 2 days ago. It appears that many people have had this problem but I was not able to find an established solution. Does anyone know how to handle this on win10 pro?

    Thanks

     

     

    • 5615

      In reply to norton2002:

      Yep. Welcome to the (very big) club.

      As I said earlier: "Sometimes, Windows 10's downloading of updates brings the network to its knees. We haven't quite gotten it to fully respect QoS settings, yet."

      And we have the ability (for now) to somewhat control Updates since we use Win10 Pro -- and yet, we still have network issues. Imagine all the Home users who can't disable automatic updates and whose networks are getting hammered by updates downloading (and/or uploading if they haven't disabled the Internet peer-to-peer option) who have no idea what's going on. I'm actually surprised that aspect of Windows 10 hasn't become a bigger issue, given how dramatically it can impair network performance.

    • 180

      In reply to norton2002:

      As a temporary fix, I'd try setting the connection to metered, which should prevent the computer from downloading updates over that connection. Turn that metered setting off overnight and just leave the system on, with power settings so it doesn't sleep, and see if it finishes downloading whatever it's attempting to grab then.

      • 9341

        In reply to Polycrastinator:

        The wi-fi connection was also hogging my bandwidth and I did set it to metered and that solved it. I now check for updates manually every few days.
        The problem with the wired connection is that I do not see how to set it to metered. Do you know how to do it?
        I googled some registry hack to meter the wired connection but there is no consensus that it works.
        There has to be a community wide solution to this or else win 10 is useless for those who do not have mega pipes to the internet.

        • 5530

          In reply to norton2002:

          if the wi-fi connection was also hogging your bandwidth but was still able to load webpages normally then the problem isn't Microsoft Update. The thing is, Windows/Microsoft Updates use the Background Intelligent Transfer Service, so when you are loading webpages and stuff, it should take precedence and the update should either slow down or pause.

          • 5615

            In reply to FalseAgent:

            One would think (and hope) that the user trying to actually use the PC to do something would take precedence over background OS housekeeping, but in our experience that, unfortunately, does not always (or even usually) seem to be the case in Windows 10 (Windows 8/8.1 wasn't a whole lot better, but Win10 is clearly worse). I've posted my frustration about Windows 10's lack of respect in this regard many times. We still have not figured out how to get Windows 10 Update to consistently respect network QoS settings (other than shutting it down completely) and it routinely slows the network to a crawl when we let it run.

            • 5530

              In reply to offTheRecord:

              I hear ya - you might want to do this as well. Settings > Update & Security > Windows Update > Advanced Options > Choose how updates are delivered > and then turn off "Updates from more than one place":

              • 9341

                In reply to FalseAgent:

                When I first installed win10 I reviewed all the settings and turned most of them off including this one. I also review them every time we get a major update because I believe in trust but verify.
                On the last Windows Weekly Paul said that he is writing the final tome on Windows Update. I hope he can address why the Ethernet metered setting is not honored or how we can stop updates from hogging bandwidth at the most inopportune time.

  5. 9341

    Mr. FalseAgent, you are a genius. The Ralink USB wi-fi on this pc works fine so I followed your instructions for safe mode and web access is good. (I am entering this in safe mode). Now how do I find the program causing the problem?

    • 5530

      In reply to norton2002:

      you're welcome :)

      Well, it's going to take some time. To begin with, i'd disable all Start-Up items in the task manager and then move forward from there, enabling each one to see which is causing the problem. Or you could kill unfamiliar processes in the task manager. Or you can stop (or disable) non Microsoft/Windows services.

  6. 5530

    Can you connect this PC via Wi-Fi and see if the problem persists? If yes then you can narrow it down to the problem being Ethernet specifically.

    Also, try loading webpages in Safe Mode. Boot Windows 10 into Safe Mode with Networking. Hold "Shift" while clicking restart, the screen will be taken over with a few options. Click Troubleshoot > Advanced Options > Startup Settings > and then click Restart. After Windows restarts, you will be presented with a list of options, it should be F5 to enter Safe Mode with Networking.

    If you can load webpages just fine in Safe Mode then there is nothing wrong with Windows or your Ethernet. Rather, you probably have a third-party program running the background that is causing the issue.

Leave a Reply