Windows won’t let me in-place upgrade to 1903

Avatar
13

Hi, I’m hoping that some of you fantastically helpful folks might be able to point me in the right direction.

I’m unable to update to 1903. I’m at work right now so do not have access to the machine, but I get various errors in the Update section of Settings. I went through the trouble of wiping the update history and files, and dowloaded the self-starting Windows Update. This ran (once I had wiped the update history), and got to the point of the install selection, but the first two are greyed out. It will only let me go forward with a clean install. I then tried the ISO by rebooting to a USB drive with a fresh copy of the 1903 update thanks to the media creation tool – but it too will only let me do a fresh install.

I’ve done some searching but things are inconclusive. Many mention language differences, but I’m set to English-US. I have ensured that I have all updates prior to 1903. I have enough room on the drive (which it was complaining about previously).

In order to ensure there was enough room on the drive, I actually moved a good amount of data from c: to d:, thanks to the very helpful folks who answered my questions in this thread. I’ve read at various semi-believable places that perhaps it is this move that is causing the problem. Regardless, I don’t want my drive formatted if I can help it.

Is there anyone that can give me some direction on getting the install to work without forcing it to scrub my drive first? Thank you in advance.

Martin.

Comments (13)

13 responses to “Windows won’t let me in-place upgrade to 1903”

  1. Avatar

    lvthunder

    Without knowing the specific errors everyone will just be guessing.

  2. Avatar

    crp0908

    Have you tried downloading and running Microsoft's tool called setupdiag for troubleshooting upgrade failures? I can't post a hyperlink here but you should be able to find it using a search. This tool reads and summarizes the panther log files, sometime found underneath C:$Windows.~BT during failures. For more details on file paths, search for "Log files that are created when you upgrade to a new version of Windows."


    This tool doesn't find every possible problem but it does find the more common problems like the Intel Audio driver issue for the 1809 feature upgrade.


    By the way, what version are you on now? 1809?

  3. Avatar

    ommoran

    To clarify my question - I don't care about the error codes. I can get around them using the ISO from the media creation tool. My problem isn't the error code. My problem is that there are three options presented for the install from the ISO, two of which are greyed out - meaning that I can't do an in-place install and keep my data. My only choice is to blow away the PC - something I'm not overly interested in doing.


    Any way to get the other two options to be selectable? Any idea what is causing them to be greyed out?

    • Avatar

      wright_is

      In reply to ommoran:

      Yes, but the error codes tell you where the problem lies, which is also why only the "blow it away" option is available.

      Probably an application/driver that isn't compatible or something with the way the user account is configured is causing compatibility problems.

  4. Avatar

    madthinus

    You must launch the setup from the flash drive or ISO from within Windows if you want to do an inplace install. If you boot from the flash disk it will do a clean install, not an inplace upgrade. If you are upgrading from an older build of Windows 10, use the upgrade assistant, I found that works well and it is less error prone.

  5. Avatar

    Lauren Glenn

    Why even use the USB stick? Just create the ISO using the media creation tool and then double click the ISO and run setup.exe

  6. Avatar

    ommoran

    I finally got an answer that fixed it. Despite what much of the documentation had said, it wasn't an issue with the default language installed - that was already US English.


    In fact, the issue was to do with the default location for the installation of Program Files and Program Files (x86). Because I had moved those some time back, this was causing the inability to install.


    Editing the registry to point back to the default c: made all of the difference, and the update went smoothly.


    Thanks to EVERYONE for your help. Just in time for 19H2 to drop!

Leave a Reply